Sign me up Login

Details about package "wasabi"

Name: wasabi
Uploader: Anastasiia Iurshina <Anastasiia.Iurshina@gmail.com> (Debian QA page)
Description: python3-wasabi - Lightweight console printing and formatting toolkit (Python 3)

Package versions

Version 0.5.0-1

Information

Version: 0.5.0-1
Uploaded: 2020-01-12 14:57
Source package: https://mentors.debian.net/debian/pool/main/w/wasabi/wasabi_0.5.0-1.dsc
Distribution: unstable
Section: python
Priority: optional
Closes bugs: 835854 894629

QA information

Comments

  1. This package closes the wrong ITP. Spacy is a separate application, unrelated to this package. Further, the change log should only contain the 'Initial packaging' entry and not mention the new version.
    
    debian/control suggests python-wasabi-doc, but this package does not exist. The maintainer is listed as Debian Science, are you a part of that team and is this package being maintained under it? If so, you should add an additional line 'Uploaders: Anastasiia Iurshina <Anastasiia.Iurshina@gmail.com>'. It is also missing the VCS-* lines describing where the package version control is. Please use these to point people to where the development of the package happens. You should remove commented out lines in debian/control. You are missing a build-dependency on python3-pytest
    
    In debian/copyright - you are missing the actual licence texts for MIT and GPL-3. Are you sure you want to licence the debian/ directory files under the GPL and not MIT? This may causes issues if you want to send patches back upstream that you carry in the Debian package.
    
    debian/rules - please delete the boilerplate comments
    Needs work Kyle Robbertze at 2020-02-11 14:07:53.643579