Sign me up Login

Details about package "python-rfid"

Name: python-rfid
Uploader: Philipp Meisberger <team@pm-codeworks.de> (Debian QA page)
Description: python-rfid - Python 2 written library for an 125kHz RFID reader
python3-rfid - Python 3 written library for an 125kHz RFID reader

Package versions

Version 1.2

Information

Version: 1.2
Uploaded: 2019-02-28 11:20
Source package: https://mentors.debian.net/debian/pool/main/p/python-rfid/python-rfid_1.2.dsc
Section: python
Priority: optional

QA information

Comments

No comments

Version 1.2

Information

Version: 1.2
Uploaded: 2019-02-28 11:00
Source package:
Section: python
Priority: optional

QA information

Comments

No comments

Version 1.2

Information

Version: 1.2
Uploaded: 2019-02-25 08:50
Source package:
Section: python
Priority: optional

QA information

Comments

  1. Hello,
    
    thanks for the package. A few remarks:
    
    1. It seems that you have a single repository for the source package and for the Debian packaging of it. It would be much better to separate them by leaving the source package in GitHub (as it is now), and developing Debian packaging specific part in a packaging repository on https://salsa.debian.org.
    
    2. debian/python-rfid.postinst attempts to remove files from /usr/local/ after installation of the package. This must not be done.
    
    3. Most of the work done in overrides in debian/rules seem to be standard. Could you try building with the content of debian/rules replaced with the following:
    
    #!/usr/bin/make -f
    
    export PYBUILD_NAME=rfid
    
    %:
            dh $@ --with python3 --buildsystem=pybuild
    
    This should also supersede the need of debian/*.install files.
    
    4. Package says that it works only with EM4100 protocol. Is this the most popular RFID protocol? If not, the name of the package, pyrfid, sounds a bit too generic IMHO, as there might be other RFID protocols with Python bindings. Name pyrfid-em4100 would sound more accurate to me, but it's surely up to you.
    
    5. Package has lintian warnings. Most of them are (should be) self-explanatory and aren't difficult to fix.
    
    Best,
    Andrius
    Needs work Andrius Merkys at 2019-02-26 09:23:40.994341

Version 1.2

Information

Version: 1.2
Uploaded: 2019-02-22 11:41
Source package:
Section: python
Priority: optional

QA information

Comments

No comments