Sign me up Login

Details about package python-docker

Name: python-docker (PTS)
Uploader: Shane Frasier <maverick@maverickdolphin.com> (Debian QA page)
Description: python3-docker - Python 3 wrapper to access docker.io's control socket

Package uploads

Upload #1

Information

Version: 4.1.0-1.2~bpo10+1
Uploaded: 2021-04-15 19:10
Source package: python-docker_4.1.0-1.2~bpo10+1.dsc
Distribution: buster-backports
Section: python
Priority: optional
Homepage: https://github.com/docker/docker-py
Vcs-Git: https://salsa.debian.org/docker-compose-team/python-docker
Vcs-Browser: https://salsa.debian.org/docker-compose-team/python-docker
Closes bugs: #937714 #958577

Changelog

 python-docker (4.1.0-1.2~bpo10+1) buster-backports; urgency=medium
 .
   * Rebuild for buster-backports.
 .
 python-docker (4.1.0-1.2) unstable; urgency=medium
 .
   * Uploading source-only.
 .
 python-docker (4.1.0-1.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Add python3-distutils runtime depends. (Closes: #958577)
 .
 python-docker (4.1.0-1) unstable; urgency=medium
 .
   * New upstream version 4.1.0
     - Refresh patches
   * Use secure copyright file specification URI.
   * Set upstream metadata fields: Repository.
   * Bump debhelper from old 10 to 12.
   * Bump Standards Version
   * Drop Python3-Version field.
     Minimum required version is shipped in oldstable
 .
 python-docker (3.4.1-4.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Drop python2 support; Closes: #937714

QA information

Comments

  1. I created this backport because I am trying to build a backport for docker-compose and this is a necessary precondition for that.  The version of docker-compose in Bullseye requires python3-docker >= 4.0.0.
    Shane Frasier at April 15, 2021, 7:41 p.m.