Sign me up Login

Details about package licensecheck

Name: licensecheck (PTS)
Uploader: Ryan A. Pavlik <ryan@ryanpavlik.com> (Debian QA page)
Description: licensecheck - simple license checker for source files

Package uploads

Upload #1

Information

Version: 3.0.46-1~bpo10+1
Uploaded: 2020-03-27 16:23
Source package: licensecheck_3.0.46-1~bpo10+1.dsc
Distribution: buster-backports
Section: admin
Priority: optional
Homepage: https://metacpan.org/pod/App::Licensecheck
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/licensecheck.git
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/licensecheck
Closes bugs: #948891 #951726

Changelog

   * Rebuild for buster-backports.
 .
 licensecheck (3.0.46-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release
 .
   [ Jonas Smedegaard ]
   * tighen (build-)dependency on libregexp-pattern-license-perl
   * copyright:
     + change general license to AGPL-3+
     + update copyright holders
 .
 licensecheck (3.0.45-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release
     + try fallback encoding per-file
       (i.e. restore explicit encoding for subsequent file);
       closes: bug#951726, thanks to Dominique Dumont
 .
   [ Jonas Smedegaard ]
   * update debhelper;
     build-depend on debhelper-compat (not debhelper)
   * declare compliance with Debian Policy 4.5.0
   * tighen (build-)dependency on libregexp-pattern-license-perl
     (otherwise one SSLeay-related test fails)
 .
 licensecheck (3.0.44-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release(s)
 .
   [ Jonas Smedegaard ]
   * fix watch file
   * build-depend on libencode-locale-perl libtest2-suite-perl
     libunicode-linebreak-perl;
     (build-)depend on libmoox-struct-perl;
     tighten (build-)dependency on libregexp-pattern-perl
     libregexp-pattern-license-perl;
     relax (build-)dependency on strictures;
     stop build-depend on libtest-requires-perl libuniversal-require-perl
   * make tests strict;
     fix set LC_ALL (not LANG) during tests;
     enable encoding tests
 .
 licensecheck (3.0.42-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release(s)
     + fix gracefully skip to next file on failure decoding a file
       (broken since release 3.0.38);
       closes: bug#948891, thanks to Dominique Dumont
 .
   [ gregor herrmann ]
   * autopkgtests: skip use.t
   * autopkgtests: set PERL5LIB for smoke test.
   * autopkgtests: add empty debian/tests/pkg-perl/syntax-skip
 .
   [ Jonas Smedegaard ]
   * build-depend on libtest-command-simple-perl
     (not libtest-script-perl)
   * autopkgtests: fix override path to licensecheck in environment;
     thanks to Gregor Hermann for the suggestion
   * tests: set licensecheck script executable
   * autopkgtests: skip t/encoding.t (fails to setup UTF-8 environment)
 .
 licensecheck (3.0.41-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release(s)
 .
 licensecheck (3.0.40-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release(s)
 .
   * (build-)depend on libarray-intspan-perl liblist-someutils-perl
 .
 licensecheck (3.0.39-1) unstable; urgency=medium
 .
   [ upstream ]
   * new release(s)
 .
   [ Jonas Smedegaard ]
   * (build-)depend on liblog-any-perl liblog-any-adapter-screen-perl
     libre-engine-re2-perl;
     tighten (build-)dependency on libregexp-pattern-license-perl
     libregexp-pattern-perl
   * declare compliance with Debian Policy 4.4.1
   * Update watch file:
     + Simplify version regex.
     + Rewrite usage comment.
   * enable testsuite
   * refresh patch 2001
   * export LANG=C.UTF-8 during tests
   * temporarily relax to ignore test failures
 .
 licensecheck (3.0.36-1) experimental; urgency=medium
 .
   [ upstream ]
   * New release(s).
 .
   [ Jonas Smedegaard ]
   * Tighten (build-)dependency on libregexp-pattern-license-perl.
     (Build-)depend on libregexp-pattern-perl.
     Stop build-depend on libtest-roo-perl.

QA information

Comments

No comments