Sign me up Login

Details about package geant4

Name: geant4
Uploader: Stephan Lachnit <stephanlachnit@protonmail.com> (Debian QA page)
Description: python3-geant4 - physics simulation toolkit - Python implementation
geant4-doc - physics simulation toolkit - documentation
geant4 - physics simulation toolkit

Package uploads

Upload #2

Information

Version: 10.6.3-1
Uploaded: 2020-11-27 15:00
Source package: geant4_10.6.3-1.dsc
Distribution: unstable
Section: science
Priority: optional
Homepage: http://geant4.web.cern.ch/
Vcs-Browser: https://salsa.debian.org/science-team/geant4
Vcs-Git: https://salsa.debian.org/science-team/geant4.git
Closes bugs: #965964

Changelog

 geant4 (10.6.3-1) unstable; urgency=medium
 .
   * Initial release (Closes: #965964)

QA information

Comments

No comments

Upload #1

Information

Version: 10.6.2+ds.1-1
Uploaded: 2020-07-24 15:48
Source package: geant4_10.6.2+ds.1-1.dsc
Distribution: unstable
Section: science
Priority: optional
Homepage: http://geant4.web.cern.ch/
Vcs-Browser: https://salsa.debian.org/science-team/geant4
Vcs-Git: https://salsa.debian.org/science-team/geant4.git
Closes bugs: #965964

Changelog

 geant4 (10.6.2+ds.1-1) unstable; urgency=medium
 .
   * Initial release (Closes: #965964)

QA information

Comments

  1. when trying to build I get:
    
    CMake Error at /usr/share/cmake-3.16/Modules/FindQt4.cmake:1314 (message):
      Found unsuitable Qt version "5.12.8" from /usr/bin/qmake, this code
      requires Qt 4.x
    Call Stack (most recent call first):
      cmake/Modules/Geant4InterfaceOptions.cmake:117 (find_package)
      cmake/Modules/G4CMakeMain.cmake:64 (include)
      CMakeLists.txt:50 (include)
    
    not sure if qt4 is still available (i think not very much so), but getting that
    indictates me the build-depends are not correct.
    
    not sure about the license discussion in the ITP, but thank you for packaging geant4, we need it too!
    Needs work Gürkan Myczko at Aug. 25, 2020, 6:29 a.m.
  2. addendum, https://geant4-forum.web.cern.ch/t/geant4-10-6-and-qt/1472/2
    looks like missing b-d
    Needs work Gürkan Myczko at Aug. 25, 2020, 6:31 a.m.
  3. geant4-data distributes two Microsoft Arial fonts: /usr/share/Geant4-10.6.2/fonts/*.ttf
    
    one is even named helvetica.ttf, but that's plain wrong:
    
    $ otfinfo -i /usr/share/Geant4-10.6.2/fonts/helvetica.ttf 
    Family:              Arial
    Subfamily:           Regular
    Full name:           Arial
    PostScript name:     ArialMT
    Version:             MS core font:V2.00
    Unique ID:           Monotype:Arial Regular:Version 1 (Microsoft)
    Trademark:           Arial® Trademark of The Monotype Corporation plc registered in the US Pat & TM Off. and elsewhere.
    Copyright:           Typeface © The Monotype Corporation plc. Data © The Monotype Corporation plc/Type Solutions Inc. 1990-1992. All Rights Reserved
    Vendor ID:           Mono
    $ otfinfo -i /usr/share/Geant4-10.6.2/fonts/arialbd.ttf 
    Family:              Arial
    Subfamily:           Bold
    Full name:           Arial Bold
    PostScript name:     Arial-BoldMT
    Version:             MS core font :V2.00
    Unique ID:           Monotype:Arial Bold:Version 2 (Microsoft)
    Trademark:           Arial® Trademark of The Monotype Corporation plc registered in the US Pat & TM Off. and elsewhere.
    Copyright:           Typeface © The Monotype Corporation plc. Data © The Monotype Corporation plc/Type Solutions Inc. 1990-1992. All Rights Reserved
    Vendor ID:           Mono
    
    Details about distribution of their stuff (it's not DFSG compliant)
    https://docs.microsoft.com/en-us/typography/font-list/arial
    Needs work Gürkan Myczko at Aug. 25, 2020, 11:08 a.m.
  4. Thanks for the reviews. Geant4 definitely builds with Qt5, maybe I forgot a b-d in control.
    Stephan Lachnit at Aug. 26, 2020, 9:23 a.m.
  5. Yep, it's definitely: libqt5opengl5-dev which is missing. I'm using your package on Ubuntu 20.04 and Ubuntu 18.04.
    Needs work Gürkan Myczko at Aug. 28, 2020, 4:20 p.m.
  6. Worked on the package again, upload should be coming soon. Not uploading the dataset because it takes too long with my current internet connection.
    
    It's now split into two packages:
    https://salsa.debian.org/stephanlachnit/geant4
    https://salsa.debian.org/stephanlachnit/geant4-data
    
    Still has the fonts issue, but that won't change without dfsg repack which I don't have the time for currently.
    Stephan Lachnit at Oct. 28, 2020, 9:48 p.m.
  7. I've had a font issue as well, with stacer, I replaced the font with a free one (fonts-league-spartan), that could also work for you?
    Gürkan Myczko at Oct. 29, 2020, 6:44 a.m.
  8. Fonts will be fixed in Geant4 10.7.x: https://bugzilla-geant4.kek.jp/show_bug.cgi?id=2267
    Stephan Lachnit at Oct. 29, 2020, 9:35 a.m.
  9. https://github.com/Geant4/geant4/pull/15 you're welcome, i really hope they will release 10.7.x soon, and that you get it into the next stable...
    Gürkan Myczko at Nov. 25, 2020, 1:50 p.m.
  10. Thx! Geant 10.7.x should be released in December afaik. I'll try my best yo get it into Debian 11.
    Stephan Lachnit at Nov. 26, 2020, 9:33 a.m.